Failed processing of large Insta360 ONE RS 1-inch videos

Update TL;DR : here is guide for Insta360 ONE RS 1-inch owners that you might find useful: Branko Kokanovic's Diary | Insta360 ONE + Mapillary workflow guide | OpenStreetMap

I recorded lot of videos and extracted .mp4 and .gpx. All videos are 10-15 mins long with around 20GB in size. I uploaded them with Desktop Uploader and mostly all failed [1] after couple of days. However, sequences are still visible in app and online. Support cannot help me, best they said is “split file into smaller files” which I don’t know how to do.

So, some questions I have for Insta360 users:

  • how did you upload your 360 videos? Does retry helps? Do you also upload 20+Gb files? Is Mapillary failing because of file sizes, because of time length or something else, what are your experiences?
  • if I have .mp4 and .gpx, how to split it into smaller (2, 3, 4) smaller files with different segments, anyone knows? Support suggested FFMpeg, but not sure if FFMpeg can deal with spliting .gpx?
  • Should I just upload and retry again? Will that help? I am asking because I don’t want to duplicate sequences and I still see failed sequences.
  • Should I just give up uploading video and use mapillary_tools to extract images and embed GPS info in EXIF and upload these?


I have not used Insta360 before. But I will advise you.

There is an app called LosslessCut that runs on Windows. It can split mp4 videos.

First, split the mp4 video to the proper size (<2GB). Then try the GPX extraction and upload.

Did you get the GPS data with a GPS remote from insta360?

Hi, I have an INSTA360 TITAN. At the moment I have only uploaded one 10GB video. The procedure I followed is this: I downloaded the 8 HD videos from the SD cards with a USB docking station directly with the Insta360Stitcher program. I did the stitching. So once I obtained the complete mp4 file, through ExifTool using the command “exiftool -api largefilesupport -p gpx.fmt -ee C:\vid.mp4 > C:\vid.gpx” I created the GPX showing the same video file name. Then I uploaded everything with the Mapillary desktop uploader. UPLOAD time about 1 hour, image processing time: 4 days.At the moment the only problem is that the 360 degree images published on Mapillary say “Captured with Unspecified” instead of “Captured with INSTA TITAN”. I didn’t understand why. The metadata indicating the brand and model of the camera is probably missing from the mp4. With software “lossless-cut” I could add it by hand. What attribute should I indicate?

Is that app works with .insv files (from Insta360)? Because if it is - great, I would even get Windows to split it. But if it is working with .mp4, I already know how to split .mp4. What I don’t know is how to split .gpx and .mp4 at exactly same times, so they are in sync!?

Yes, from .insv files and then using Insta studio that produced .mp4 and .gpx.

Seems like you already had .gpx inside .mp4. Insta studio is having it as separate file. Not sure if I can put .gpx in .mp4 and then split .mp4 into multiple files?

So I have some bad news about insta360 and GPS. I’ve used an X3 before and it was absolutely awful at uploading to anything. I tried working with it for 6 months and barely managed to get anything working from it, so I switched back to GoPro.

It seems that the GPS taken from the remote is somehow incompatible with google maps and also Mapillary. Videos with GPS taken from a phone uploaded reliably but they were also reliably terrible and extremely inaccurate at best and completely in a nearby ditch at worst.

Out of more than the 100 insv videos that I took with my X3 using my GPS remote, only ONE worked on Mapillary.

It seems the pro models like the titan work better since their cameras have a GPS module that actually works. But since you are using a model that doesn’t have GPS built in like GoPro does, I am pretty sure that it unfortunately isn’t possible to upload many, if any, videos taken on a non pro model insta360 camera.

I’m also not sure how to split insv files. I only recorded 30-60 second videos when I was trying to use mine before. Insta360 studio was not much help to me but maybe you will have more luck at it than me.

I also changed my resulting .gpx to snap it to roads (results are much better that way, I would say). However, now I am not sure why do you think upload fails? Due to GPS/.gpx (for some reason) or due to size of video? If it is former, I can try with original .gpx (but you say that it also do not work). If it is latter, I have no solution.

Does anyone knows if these uploaded and failed sequences will be removed at any point?

I managed to find the command line for the “mapillary_tools” which allows me to make satisfactory uploads “mapillary_tools process_and_upload --user_name “xxxxx” --video_geotag_source gpx
d:\video.mp4”. In the same folder I also have the *.gpx file which has the same name as the mp4 video. However the “Captured with” reference remains “Unspecified”. How do you fix it?

If you are asking me, I don’t even know where to look for “Captured with”, nor did I upload using mapillary_tools (just using regular desktop uploader).

Hi @stalker314314

Here are the instructions for how Mapillary recommends setting up and shooting with the Insta360 x3. In particular, you’ll notice that timelapse video is recommended (not regular video). This creates much smaller file-sizes which are much more likely to be processed successfully (and are faster for you to upload as well).

In general large filesizes will cause problems depending on how busy the system is (something we are working on improving).

If you want to edit gpx to split, etc for your existing recordings you can do that using a tool like

In general the Insta360 x3 is not our top recommended camera (you’ll generally find the GoPro Max or PANOX V2 easier to work with due to some of these issues).

Thanks @boris for chiming in. Regarding camera choice - it was not my choice, so I will not comment on that:) Regarding video vs timelapse, I was reading somewhere that timelapse is worse quality, so this is why I opted for video (now I an stuck with lot of videos I cannot upload). You suggest Insta360 owners should use timelapse for Mapillary?

Finally, most important thing - I tried to split large video into 2 videos. I used commands like these:

ffmpeg -i input.mp4 -c copy -strict experimental -map 0:0 -segment_time 00:05:00 -f segment -reset_timestamps 1 out%03d.mp4`
exiftool -api LargeFileSupport=1 -tagsFromFile input.mp4 -all:all out000.mp4

(I will write better blog about this once I am out of woods). Regarding .gpx, I just split it to 5 min chunk.

I tried with 10 second and 5 min samples, but now Mapillary is just stuck for 4 days saying “Processing 3 captures from …” and I don’t see it being processed in right pane. Also, old sequences are still visible in “failed” state in app. Will they be removed?

Yes, give it a couple more days, but basically high resolution, high fps videos are more likely to fail, so yes, we recommend timelapse mode. I recommend waiting on the processing ones for several more days to see if they succeed and pop into the feed or fail.

Failed sequences should be removed from your feed after about 2 weeks.

I managed to upload everything. It took some coding and Linux, but finally it is done!

In case anyone else have problem, here is blog post where I explain process with Insta360 ONE RS 1-inch (which I forgot to mention in the beginning, updating title):

Hopefully next person with this camera can use it as a guideline (or just contact me).


Awesome work!!