BUGREPORT: mapillary_tools: interpolate_directions option does not work?

Hi All,

After taking some tries with mapillary_tools for batch processing and upload I ended up with doing most sensitive part of geotagging manually (using exiftool)

Since gpx tracks in osmand do not capture directions (course/heading) - this needs to be interpolated and added during processing.

I have tried some tests and discovered that for some odd reason directions are not interpolated/written under certain scenario

Case 1:
mapillary_tools process --advanced --import_path "path_to_images" --user_name "user_name" --interpolate_directions
DOES NOT interpolate directions based on exisiting GPS Exif tags

Case 2:
mapillary_tools process --advanced --import_path "path_to_images" --user_name "user_name" **--geotag_source "gpx" --geotag_source_path "path/to/track"** --interpolate_directions
DOES interpolate

Difference between 1 and 2 is that in case 1 no geotagging is applied by MT, existing tags are used;
in case 2 - mapillary_tools are doing geotagging from gpx track themselves (even if GPS Exif already present)

Looking at the documentation I guess this is not an expected behavior and --interpolate_directions option should be working in both cases.

Hi,

could you test your case 1 with the addition of:

– overwrite_EXIF_direction_tag

?

weird…
I was trying –overwrite_EXIF_direction_tag today in the morning before posting this.
No effect, 0 heading was just written to image EXIF

Now, I have tried again the --interpolate_directions with same sample data and… magic… it worked!
Heading was calculated, no matter if I have used the option to update Exif meta or not.

The only explanation I could imagine is that interpolate_directions option is using some ‘online’ cloud service to do the calculations… which was not apparently working yesterday and today in the morning.

Yesterday I have processed 25000 images with the mapillary_tools and heading was not interpolated.
Now, running SAME command, using same tools, same PC and same imagery - heading is calculated.

I will probably submit a question to mapillary support by e-mail and will ask them to run a batch ‘normalization’ for my 60+ sequences from yesterday.

And to stay on a safe side, I would probably switch to another GPS track recording app on my phone.
Exiftool supports geotagging of headings if available in source gpx.

Unfortunately OsmAnd (which I like a lot) does not save course tags in the gpx files.
Locus does that job quite well.