[bug report] Mapillary app iPhone faults with YI 360

As to stitching, movie interval etc… ignore all that… I can script around that.

I’ve got my workflow for processing MP4 files as good as figured out for a perfect workflow (just need to clean up my code…)

FYI stitching:
I naturally want the best, so I want the highest resolution. And I want the best stitching possible.
At the highest resolution the camera can not stitch. And I don’t mind that, because the stitching of the camera is nice, sometimes even good. But Hugin is (as good as) perfect with stitching. So I do that part in the “post processing”

Do I dare… ahh well fortune favours the bold :stuck_out_tongue:

@Anders, any news?
If you tried to fix things in the latest update, it didn’t work:

PS: “AD…ED” is a bit odd for guessing for it to be the place to add a camera…

With app version 4.16.6

When the camera is connected via WiFi, the Mapillary app finds the “XiaoYi - YI360” (“YI 360”), the camera beeps!

When I tap “AD…ED” the app is able to read the “Battery remaining”

When I want to take an image, the camera beeps… it takes an image… but I still get the error screen posted earlier.

This is so frustrating… you feel like you’re one inch away from completing a marathon but can’t cross the finish line because your foot got stuck on a huge amount of chewing gum :cry:

PS: specially since the native YI360 app stopped working on my iPhone 13

Ok, might I suggest a simple and straightforward approach?

Could you add this option in the settings:

Ignore errors and continue: yes/no

Set default to no (as it is now) and when I could set it to YES, I would be able to use the camera again AND use it with the Mapillary app!

Could you add this option?

I have time to look into it this quarter. If you (or someone else) sends the camera to Mapillary I will try to make it work. No promises that I can make it work though, but I’ll do my best.

1 Like

Could you make an appointment with @mickewall ?

On the other hand, a more generic solution for those strange people with their strange camera’s, would my “ignore error and just continue” be a good idea (no camera needed then)?

Otherwise, I’ll send you mine.

Sure, any way to get it in my hands is ok. We won’t purchase it though, it’s too uncommon plus it doesn’t do onboard stitching and we don’t want unstitched images on the platform.

It’s possible, but I have to see where the error is and if I can ignore it. It could be that the camera simply stops accepting the capture command for instance, then I can’t do anything. But let’s see.

And I don’t recommend the camera anymore. I still have the opinion the hardware is great for the price (5.7k image for less then $ 200) but the software support of the camera by YI is horrible… But I can’t sell it to my self just yet to buy the QooCam 8k (my new love :wink: ) I have barely used the YI…

The error occurs immediately after the “take an image command” has been sent from the Mapillary app to the camera. The response (if any) must be not what’s expected, so the error comes on the screen. When I click the error away I can immediately take an other picture (etc).

I expect the “error screen” to be a function, so I thought that before you show the error, check if the setting “ignore_and_continue” is set to “true” and then just return without showing the error?
(I’m not an app builder, so forgive me if I’m assuming something as a PHP/Perl/bash/JS/HTML developer that is not the case here…).

If you could add that option, I think it would fix my problem. And also maybe an option to use for other (future) “exotic camera’s”!