Android app without internal compass - how to capture?

I have as Android phone without a working internal compass that I used to capture additional images from the side window.
In Mapillary app I set “Compass locked forward”, then successfully captured some sequences.

At first I just uploaded it to Mapillary and tried “Correct angles” in the Edit mode:

Camera was pointing at *90* degrees to the forward direction.

However, it didn’t work - sequence still shows incorrect direction (forward).

For the next sequence I used a script from Mapillary tools, that corrected some EXIF tag. If I open these photos in JOSM, direction is correct.

python 2016_05_04_09_34_36_646/ 90

However, Mapillary still shows incorrect direction. I guess it used incorrect direction from the Mapillary tag (which?), not the direction written by

What is the best work flow in this situation?
Should I just strip Mapillary tags from images and use, then

Mapillary uses the exif-description-tag to store the direction and other mapillary tags.
After you changed the exif-direction-tag you should run to copy the data from the direction-exif-tag to the description tag, then proceed as usual.

Thank you, it worked. I don’t know how I missed this tool.