Heads up regarding ffmpeg processing BlackVue videos from Debian Bookworm/Deb-multimedia

I have not run this completely to ground, but it appears that the latest deb-multimedia 10:6.0.1 now fails with a header error trying to decode frames from a BlackVue DR900S camera. eg;

[mov,mp4,m4a,3gp,3g2,mj2 @ 0x55e6a7a762c0] error reading header
20231119_115953_NF.mp4: Invalid data found when processing input

So if I try to run the tools locally it may fail. (I upload the mp4’s direct though)

If anyone knows a way to ignore the error would you please advise as I use frames for local OSM work

Note, downgrading back from 10:6.0.1 to 10:6.0 (dpkg install) versions in /var/cache/apt was/is a viable workaround.

Hi @bob3bob3 - do you need ffmpeg for these uploads or are you able to upload directly using mapillary_tools or the desktop uploader? They should be able to process the mp4 files directly. Give it a go and let us know what you find. cc: @adalvit

Hi @boris @adalvit

The direct upload works fine. I did a small upload run to test if the Mapillary server processing was affected. I was going to suggest your dev/server people keep this in mind.

I do however also locally process the videos, so I can filter and do OSM edits. bob3bob3's Diary | OpenStreetMap if you wish to read. I also sent a document to @eneerhut

I am using one of the Mapillary supplied BlackVue/firmware combinations. I run at 2FPS which is probably quite rare. I’d suggest that the header damage was something in the original or mapillary firmware. If I am the only one with the problem the workaround I have in place works fine.

As I recall ffmpeg always quoted a warning on BV videos, but since it always worked I haven’t examined that. I’ll check that later today.

1 Like

Got it, thanks for the explanation on your custom workflow!

Thanks Bob, it’s appreciated, I’ll check how we are selecting the internal version!

@boris @adalvit

Warning message from (downgraded) ffmpeg deb-multimedia 10.6.0-dmo6 on extracting frames;

ffmpeg -i 20231119_090257_NF.mp4 -s 3840x2160 -vf “select=eq(pict_type,I)” -fps_mode vfr -qscale:v 1 -qmin 1 -qmax 1 %3d.jpg
ffmpeg version 6.0 Copyright (c) 2000-2023 the FFmpeg developers built with gcc 12 (Debian 12.2.0-14)

[mov,mp4,m4a,3gp,3g2,mj2 @ 0x562195ee1ec0] Found duplicated MOOV Atom. Skipped it

1 Like

Just for your interest only.

@boris @adalvit

Holding back the ffmpeg version was getting difficult as its libraries had many hooks into other applications. It became almost unworkable when Bookworm upgraded to 12.5.

I have got around it by downloading a static version from Index of /ffmpeg/old-releases in my case https://www.johnvansickle.com/ffmpeg/old-releases/ffmpeg-6.0-amd64-static.tar.xz I created it as ffmpefg-600 in my /usr/local/bin and it works fine with my script now.

My BlackVue direct uploads to Mapillary continue to work fine.


1 Like

Thanks @bob3bob3 . I tested now with the packages in trixie and our internal ones, and they work smoothly. If you need to stick with deb-multimedia repos, maybe you can notify their maintainer?