Converting GoPro video to images

I have some GoPro videos that I would like to upload to Mapillary. I’m on Windows, have the latest command line tools and installed ffmpeg. I have the mp4 files, as well as .thm and .lrv files. When I follow the suggested command for GoPro videos, the expected amount of images are created, BUT they don’t have GPS info. I also get the below error:

Any idea what is going wrong here?

Hey @joostjakob, do you have a mapillary_image_description.json generated after processing your videos? If yes, does it look valid?

The upload command then takes the image description file as the input, zip images with the specified metadata, and then upload.

1 Like

No json file was created by the command. I tried with a different group of files and have the same result as before.

This is sampling phase so no JSON produced yet.

Could you run the ffmpeg command given in the trace stack (i.e. fmpeg -i "H:\\mapillary\\test filmpje\\GP3057.MP" ...), and see what ffmpeg prints out?

There you go:

Thanks @joostjakob. I meant run the full command here:

Thanks for helping tao. If I try

'ffmpeg', '-i', 'H:\\mapillary\\test filmpje\\GOPR3074.MP4', '-y', '-nostats', '-loglevel', '0', '-hide_banner', '-codec', 'copy', '-map', '0:3', '-f', 'rawvideo', 'C:\\Users\\joost\\AppData\\Local\\Temp\\tmp7gll34ri

Then it tells me that ‘‘ffmpeg’’ doesn’t exist. If I turn it into a more regular looking command, i.e.

ffmpeg -i "H:\\mapillary\\test filmpje\\GOPR3074.MP4" -y -nostats -loglevel 0 -hide_banner -codec copy -map 0:3 -f rawvideo C:\\Users\\joost\\AppData\\Local\\Temp\\tmp7gll34ri

Then I get no output at all. If I drup the nostats loglevel things (which I pressume block uninteresting stats?), then I just get some harmless info, no error notifications

Hi @joostjakob could you retry with -loglevel debug instead of -loglevel 0 here?

Well the disk I had the images on died, and the laptop I had the software on died as well. So it’ll be a while till I can look at this again. Thanks again for trying to help.