Unable to upload: The AWS Access Key Id you provided does not exist in our records

Uploads with mapillary_tools now completely fail.

<Code>InvalidAccessKeyId</Code><Message>The AWS Access Key Id you provided does not exist in our records.</Message>

What happened?

1 Like

Have the same since Friday, no response from support.

Just responded. @Richlv can you try adding --rerun to the end of your script and confirm whether that fixes it.

Sadly no - neither --rerun nor deleting the whole .mapillary subdirectory helped; I also deleted all the files in %USERPROFILE%/.config/mapillary and re-authenticated, but still no success with the upload.

I had the same problem.
So I updated the mapillary_tools (I use .exe), and now it works fine.
Oops, another problem occured. One sequence upload is fine, but it fails when second sequence uploading starts.

Using upload session *****
Uploading 1. sequence with 5 threads
Traceback (most recent call last):===========================] 100.0% ... 0 images left..
  File "mapillary_tools", line 76, in <module>
  File "mapillary_tools\commands\upload.py", line 49, in run
  File "mapillary_tools\upload.py", line 108, in upload
  File "mapillary_tools\uploader.py", line 828, in upload_file_list_manual
  File "site-packages\requests\models.py", line 940, in raise_for_status
requests.exceptions.HTTPError: 404 Client Error: Not Found for url: https://a.mapillary.com/v3/me/uploads/*****/closed?client_id=*****
[58152] Failed to execute script mapillary_tools

Thank you for the reply, @eneerhut.
Unfortunately, same as @countzero5, adding “–rerun” did not help (it might eventually result in duplicate images being uploaded, as 165 pending images in the current sequence jumped to 280).

@tankaru, glad it works for you - unfortunately, I’m stuck with some older copy of mapillary_tools. It fails to update, as it does not work with Python 3.

Python 3 support has been asked several years ago starting with https://github.com/mapillary/mapillary_tools/issues/227 , but has not arrived yet.

It seems the same issue with this thread. And no solution is provided for now.

Was able to upgrade mapillary_tools now.

After a successful upgrade (yay) got “Error, user authentication failed”.
Removed Mapillary config, re-authenticated - got an exception.

    user_name = first_image["user_name"]
KeyError: 'user_name

Added --rerun and finally it works.
Rrrrreally missing a public bugtracker :slight_smile:

@Richlv How old was your “old” version? I remember this kind of failure about a year ago that required reauth and -rerun so am concerned. I don’t have the energy (battery/solar) to rerun all my images


Thanks for confirming that the update to latest mapillary_tools worked tankaru. @countzero5 can you confirm whether you’re running the latest version of mapillary_tools?

Python 3 support is not likely to come soon, so 2.7 is required for the time being until we move to a new suite of upload tools.

Ultimately this issue was cause by security improvements on our side which impacted mapillary_tools.

The Windows binary linked to from Github still is 0.5.0:

Downloads\mapillary_tools.exe --version

Mapillary tools version : 0.5.0

Which still does not work. If there is a newer version, maybe link to it?

So I then went through the (small) headache of installing the 0.5.2 python script, and this indeed does work. For various reasons, I would prefer a build of mapillary_tools.exe , though. Any chance to get this, or did I miss it?

@eneerhut Ed would you please confirm if there were server security key/changes after about 17-19th July? (The date of my last successful upload)


The latest commit was on the 21st of July. If you’ve cloned mapillary_tools via HTTPS or SSH, you should be fine, but it appears those using one of the binaries are still encountering issues.

This is something I am still working to confirm.

Confirming python2 setup.py install will be needed to get the latest version number at present.

1 Like

I keep getting

Traceback (most recent call last):
  File "C:\Program Files\Python2.7\Scripts\mapillary_tools", line 76, in <module>
  File "C:\Program Files\Python2.7\lib\site-packages\mapillary_tools\commands\process_and_upload.py", line 162, in run
    upload(**({k: v for k, v in vars_args.iteritems()
  File "C:\Program Files\Python2.7\lib\site-packages\mapillary_tools\upload.py", line 110, in upload
    params, idx, number_threads, max_attempts)
  File "C:\Program Files\Python2.7\lib\site-packages\mapillary_tools\uploader.py", line 795, in upload_file_list_manual
  File "C:\Program Files\Python2.7\lib\site-packages\requests\models.py", line 940, in raise_for_status
    raise HTTPError(http_error_msg, response=self)
requests.exceptions.HTTPError: 401 Client Error: Unauthorized for url: https://a.mapillary.com/v3/me/uploads?client_id=MkJKbDA0bnZuZlcxeTJHTmFqN3g1dzo1YTM0NjRkM2EyZGU5MzBh

with 0.5.2 - the stuff I captured today uploaded fine, but my batch from the 24th seems to die after a few sequences.

This is really annoying. I spend more time trying to upload images than capturing them.

Add --rerun for that directory, does it help?

Just restarting without --rerun fixed it, but it took 4 or 5 attempts.