New Desktop Uploader

I just emailed saying the web uploader is down and attached a console screenshot

Sorry, I just read one message at a time.

On their status webpage it seems they observed the issue:

Identified - We’ve identified the API errors and are now working on fixing them.
Dec 29, 11:10 CET

all issues are now marked as resolved, yet uploads still fail.
bad timing with NYE

same here. uploads still fail. Not so good fix, team

1 Like

seems to have been fixed, yay. Happy NY everyone

1 Like

Sorry about the poor timing here, everyone. We still have a few things left to fix with mapillary_tools and the desktop uploader and are working on them now. Happy New Year!

1 Like

2 Januari 2020
The android and the web uploader work.
The desktop uploader does not work.
And the results are quick.

Mapillary status : everything is resolved since 30 december 2019.
But that is just for the shareholders. Or it takes days for a solution to take effect.

1 Like

After many selects, I just uploaded 23000 pictures with the web uploader in one go.
Is that a record ?

it might just be. considering the bugs in the desktop uploader, having no artificial limit for the web uploader is welcome

Thanks for the response @Brenna. Is there any ETA for this fix? I’m still sitting on >70 GB of photos to be uploaded. Using the web uploader is not feasible since it is inconvenient for already processed images, very slow and resource hungry compared to mapillary_tools.

I think Mapillary could not swallow it. These pictures from january 2 are only visible when you navigate to them from other sequences. I think about uploading the backup dashcam videos.

The processing of the pictures from two days ago seems stopped.

Hi everyone, I’m updating threads about this so please let me know if you have any further issues or questions:

Users having issues with the uploader will need to:

  • wait for the uploader to auto-update to v1.2.2
  • reprocess imagery by manually deleting the .mapillary folder created in the import path

Users having issues with _tools will need to:

  • get the latest tools binary (or update to the latest master)
  • mapillary_tools authenticate --advanced (reauthorize)
  • re-process imagery by manually deleting the .mapillary folder created in the import path or using --rerun



When may we start complaining again ? I mean, “when should the web uploaded images be fully visible ?”

I loaded about 50,000 in the last couple of days and all but 3,000 are already visible

@filipc @tastrax When did you upload the imagery that’s not showing as of now? I’ll try to see what sort of timeframe the devs are advising. Thanks!

I am not too fussed if it takes a while - they appear to be getting there slowly. I started loading them on the 8th and 9th

All is nice and dandy now. Up to the next crisis.
Of course it can never be quick enough.

Maybe I repeat … The desktop bootloader (1.2.4) does not approve of some photos 969/999 (-30). The browser loader has approved everything. Why is that?

For me Desktop Uploader has rejected images for two reasons so far:

  1. Two consecutive pictures have the same GPS coordinates. Valid at a stop but rarely my camera app or phone seems to not acquire a new position and assigns the previous one to the next picture. I use Geosetter to correct that.
  2. Something with the exif thumbnail bothers the uploader. You can remove the offending thumbnail with exiftool: exiftool -thumbnailimage= IMG_nnn.jpg