How to access to Mapillary vector tiles to show all levels (0-16)?

I need to access to the Mapillary vector tiles (???) using Leaflet as they are shown in the Mapillary web site, for example

I’ve tried to use the Mapillary vector tiles API as documented here

so using this request{z}/{x}/{y}.mapbox

but I can see the vector tiles only for levels 0 - 14 not more, then I receive a 403 (Forbidden) error.

Are there alternative ways to obtain Mapillary vector tiles or how this issue is solved by the Mapillary web site?

Any link / suggestion / example?

Thank you in advance!

Hi there,
the mapillary website (examining the network traffic here) uses also just up to level 14. we don’t generate more tiles than that, since all the data is already contained at level 14. From there you can interpolate.

Makes sense? Anything I’m missing @knikel?


@CesareGerbino Unfortunately that will not be possible with Leaflet. As @peter mentioned, we don’t generate above level 14 and the data is already contained there. The problem with Leaflet is that it cannot render the data from lower levels that it’s currently displaying. My suggestion would be to use mapbox-gl-js, which is the library we’re using at Here’s an example:

This is a bad news for me … I’ve built a little web mapping application based on Leaflet (not only with web mapping but also with other functionalities like routing and so on … ), and this means that I’ve to rebuild it.

Anyway, thanks for the reply and for the code sample: I’ve also opened a question here …, now with a bounty, if you want to reply there … could be useful for others … and you gain the bounty.Thank you!!

I’ve notice that in the sample you are using this url for the vector tiles{z}/{x}/{y}.mapbox

but I’ve seen in the Mapillary Forum (ref., that you are changing the url to access to the vector tiles to this one{z}/{x}/{y}.mvt

with these specifications

Extent: 4096
mapillary-sequences Layer (Type Line)
mapillary-images Layer (Type Circle)

I’ve also notice that some my recent sequences don’t appear in the{z}/{x}/{y}.mapbox reference but there are in the{z}/{x}/{y}.mvt reference and I’ve seen that you use this url{z}/{x}/{y}.mvt in your new mapillary interface.

Do you have some little sample like that you’ve gave me (or an update of it to use this new reference …), to use the new vector tile link? I’m not so sure that the link{z}/{x}/{y}.mapbox will be update (it seems not …)

Thank you again …

I’ve tried to use your sample code with the new vector tile reference ({z}/{x}/{y}.mvt) and it’s working fine … that’s ok!

@CesareGerbino, ah! Sorry, I didn’t realize the URL is different in your example. Glad that you found it and it works!

I feel that the vector tiles are a bit out of date, can you confirm this? When I use my MapRadar I see pretending a lot of roads not taken yet but I am quite sure I have been there.

Yes it is outdated. Please use this endpoint mentioned by @CesareGerbino{z}/{x}/{y}.mvt

The specification is at

Sorry about the documentation distributed here and there. We will get all of them in a place soon.