[BUGREPORT] video upload


Yes, that problem has been commented in the forum. The answer from Mapillary was that it’s a known issue, so I’m afraid it won’t be fixed anytime soon.

I decided to use the Mapillary Tools to upload videos. The process is not easy, but at least I found a way to continue uploading videos. You can check the process I follow to upload videos with Mapillary Tools here.


@mikelo thanks for letting me know.
Sometimes I just do not understand Mapillary decisions. If the video upload does not work just take that site offline or leave a warning or fix it. Is any of the 3 options so hard to achieve? I’ve now updated several videos resulting in wrongly located photos on the map which I then had to manually asked for deletion. Just a waist of my time. And how hard can it be to fix something that once worked. Have Mapillary lost all the code?

1 Like

Totally agree @peewee32. The legacy video upload page should be set offline until it’s fixed. Or, at least, it should warn and link these forum posts.


Legacy uploader is NOT working properly now (from Mar 16).
However, by performing an certain operation, we can upload videos successfully with the legacy uploader.

The symptom of the problem is that the coordinates at the beginning of the gpx file are used even though the time adjustment operation have been completely performed.
So, for each video I want to upload, I made a gpx file of only the time zone of that video and gave it at upload.
And with that operation, the legacy uploader can create the correct “Street-Level Imagery”.

I have described this symptom and how to handle it as follows :

Perhaps the legacy uploader can not be improved in the future.
However, it is so powerful and easy to use that I hope it will be used as it is into the future.

I am using a free app to edit gpx files.
There are many editing software. I do not describe the details because I don’t have time, but I think that I will explain how I am doing if there are many who need it.

Video uploads not working?

Thank god for the translate option in my browser :wink: (my Japanese isn’t that good :stuck_out_tongue: )

Thank you for the info. I am expecting my 360-camera to arrive shortly, which has a faster image rate in video mode (30fps, 2fps, 1 fps and lower) as to image (fastest 1 image per 2 seconds) mode so the legacy uploader is a serious option.

Can you tell me if the uploader can handle 2fps videos ?
How good is the synching?
I understand you have to manually edit the starting point. But does it end at the right spot? Do you have to do time corrections to sync the end?

1 Like

Congratulations on your camera purchase.
Well, my opinion is that I can not accept 2fps videos from Mapillary.
In my experiment, 5 fps was not accepted.
Even then, the Legacy Uploader operation will complete successfully. But no matter how long I wait, no photos appear on the map.

Both 29.97 fps and 30 fps were OK.
In the between 5 to 29.97, there should be a more efficient frame rate that Mapillary can accept.

In addition, if the frequency of key frames is reduced, the degree of compression can be increased even if the frame rate is high.
Please try an experiment.

Also, if the number is about 1 fps, using a still image uploader seems to be more efficient.

I am currently trying to upload various videos taken with THETA V and THETA Z1 to Mapillary.
The situation is summarized as follows.


The truth is not necessarily written.
I only write the facts I got in the experiment.
I believe there must be a better way.


Thanks, I hope the YI 360 works out as I am hoping!

Hmmm, then the ffmpeg option will become the way to go for me I think…

(will have to do some programming…)

1 Like

The mapillary_tools (python) video process/upload function has worked for me at 10, 5, 2 and 1FPS. I ran it succesfully at the end of April 2019 without any problem. I will be uploading another batch from about 24/5/19

I am using 30FPS BlackVue mp4’s. I process separately from upload.

I suggest an experimental decode of the YI360 video, to ensure that ffmpeg will work when the tools are launched.


I still use only legacy uploader web tools. I do not know how to use the new uploader or how to use the command line tools. I’m sorry.

I look forward to reports on uploading videos taken with your YI 360.


And I can’t even run the tools, possibly because of the nature of my operating system.

1 Like

I think we all should look for a convenient service combining gps and video into one video file. This is how it is implemented in car DVRs BlackVue.


Just some comments;

  • I am only generalizing.
  • To cover all kinds of movies and sources there should really be a standard. I would assume that since the tools have a different setting for GoPro and BlackVue that their formats are proprietary. Is there an RFC or other standard available?
  • The current BlackVue units also create a synced nmea gps file. ie the same date/time filename prefix is used for both.
  • I have heard that the Mapillary video upload service was having some trouble some months ago (I dont use it) so it might be worth messaging support to check. There was a fanfare over the desktop uploader so one might suspect that the legacy one is deprecated.
1 Like

@bob3bob3 you’re correct on the Legacy Uploader. Development efforts are being put into the Desktop Uploader which is much more robust. Mapillary_tools would be recommended in the interim for any video upload support outside of Blackvue.

Mapillary_tools are easier to install/use than ever.


Just adding the URL for the up to date mapillary_tools

Scroll down till the README.md is seen and the Package Installation section. Install/read.

I can help if you run under linux and/or want to run in a virtual environment.



translate please?


Use the system information to determine the required software version (32 or 64) and contact the software publisher.


And what OS are you running? 64 or 32 bit.

I assume the patch status is up to date and there are no unusual errors in the event viewer system log?

I dont have Windows so cant test.


32 bit windows 7


All understood. I got the same fault trying to install on a W7 32 bit PC. Any chance that it may be time to upgrade? It’s also possible to make it dual boot with (say) a Debian Linux distro. (zero money involved)

1 Like