[bugreport] some images require multiple upload attempts

After the latest app updates, in most cases after the upload finishes, there are images left not uploaded.
These were not captured after the upload started, no capture happened during the upload.

It is usually somewhere between 1 and 40 images. Repeated upload attempts will usually get rid of them, eventually - although right now I have 12 images that are uploaded and uploaded, but never disappear from the phone/app. It is not clear whether they actually get uploaded to Mapillary systems for every upload attempt.

2 Likes

Same happens to me every single time. I usually upload about 1500 images and have to restart the uploading process at least 5 times to succeed with all of them.

The same thing happened to many mobile applications when they get updated. I think sometimes it is image size or type error that got triggered in app while uploading media content.

Still a problem in the latest version.
This happens whenever image upload fails - looks like there’s no retry mechanism, or it does not work?
Easy way to trigger this is to have wifi only, start upload and disable wifi. App says all is uploaded successfully, while most of the images have not been uploaded.

Yes it’s happening on my iOS app as well.
As you can see the dialog says all is uploaded by the image count shows otherwise.
The images that are left behind are quite far from one another, so if I try uploading them again will they be part of the original sequence or will they be treated as a separate sequence?

This post was flagged by the community and is temporarily hidden.