[bug report] Mapillary app iPhone faults with YI 360

I found a 360 photographer near Malmö and sent him a mail if he could maybe help…

Otherwise, if you are unable to get your hands on a YI360 camera, I would be willing to send you mine (I do want it back offcourse :wink: ) Could that be an option?

I have also asked everyone in the company if they have one. So far the US etc are sleeping so we’ll see if I can find one here.

1 Like

The amazing thing is, I got in touch with him! And he owns a YI360 ! Luckily his English is better than my Swedish and amazingly enough he discovered Mapillary a few days ago. I asked him to create an forum account also… we’ll see… I hope.

PS: he also owns a Insta360 Pro! I asked him to upload a few of his images… curious how wel they perform on Mapillary :wink:

Yes thats me :slight_smile: Michael Wall in Trelleborg
I can upload some pictures taken with the Insta pro later this week. Right now i am working on a documentary project that takes all my time.:slight_smile:

Maby i can come in to Anders someday next week and talk to him live?

Happy weekend from


Hi @Anders,

Can you give an indication when you could get around to to fixing the Mapillary-app for the YI360?

Can @mickewall help you with this?

I have tried to disassemble the the YI360 , but I seriously run the risk of damaging the case (further) and I don’t want that… so I’ve decided to not go for that approach. An other option for an “automated button pusher” are troublesome… the fix from the mapillary app is not only ideal, but also becoming my only solution…

Otherwise I likely only can use the “frame grab option”… but that is only ideal for driving the car… for walking/cycling the “interval image option” has quite a bit more quality and is much faster for processing…

So I’m stranding a bit here… :cry:

I have made some general work to support OSC v2.1 so that might be enough to make it work with the YI360. I hope to get it out this week.

1 Like


Drop a line when I can update the app, I’ll test it!

I just released it. Might take some time for the App Store to process is but should be available soon.

Alas, I just tried the updated app. After taking one picture I still get the same error (and can click it away and take another etc.)

@Anders could @mickewall help getting the YI360 to work with the Mapillary app?

Otherwise, I would be willing to send you mine (and when you’re done, send it back naturally :wink: ) how long would you think you would be needing it?

I am certain that the YI would be a very good camera for Mapillary when your app could communicate well with the camera!
Also the high resolution and good movie interval settings are perfect for car mounts!

Then the only down sides would be: no onboard GPS and no onboard stitching at the highest resolution. But when I have created a good workflow those downsides are quite well managable.
(And offcourse I am willing to share the knowledge I am gaining)

PS: I still think you could add: if (camera_id == ‘YI 360’) { do ignore error; return true; }

I’m terribly sorry I forgot about this!

Regarding stitching, that could be a problem that I need the computer vision team to investigate how much work it would be to support this. Does it support stitching for some (lower) photo resolutions?

You mention “movie interval settings”. We don’t have movie support in the app currently, but it’s something I want to investigate at some point.

In short, what do you want the app to support?

  1. Just controlling the camera?
  2. Transferring the photos to the app and let the app add GPS data etc?
    3a. And then upload the images to Mapillary?
    3.b. Or simply transfer them to your computer?

Again, sorry for my late reply!

1 Like

Hi @Anders, thanks for the reply!

Never know what future wishes I come up with, but:

At this point I would just love it when the app would ignore the error (shown in the first post) and would just shoot images at an interval!

PS: it’s been a while, the interval setting is 1, 2, 2.5, 3 + seconds for the external camera, correct? I can manage sub second imagery … if it would be possible to set that in increments of .1 second I could squeeze out all the max images/second out of the camera :slight_smile: But first things first…

AD: I think the camera can handle one image every 1.5 to 1.8 seconds… when one want one image every 5 meters; 2 seconds per image means at most 9 km/h, 1.5 seconds between the images would mean I could cycle up to 12 km/h… but maybe I need 1.6 (it’s very hard to figure out max speed so it’s an estimate) But that’s question/request number distant second :wink:

As to stitching, movie interval etc… ignore all that… I can script around that.

I’ve got my workflow for processing MP4 files as good as figured out for a perfect workflow (just need to clean up my code…)

FYI stitching:
I naturally want the best, so I want the highest resolution. And I want the best stitching possible.
At the highest resolution the camera can not stitch. And I don’t mind that, because the stitching of the camera is nice, sometimes even good. But Hugin is (as good as) perfect with stitching. So I do that part in the “post processing”

Do I dare… ahh well fortune favours the bold :stuck_out_tongue:

@Anders, any news?
If you tried to fix things in the latest update, it didn’t work:

PS: “AD…ED” is a bit odd for guessing for it to be the place to add a camera…

With app version 4.16.6

When the camera is connected via WiFi, the Mapillary app finds the “XiaoYi - YI360” (“YI 360”), the camera beeps!

When I tap “AD…ED” the app is able to read the “Battery remaining”

When I want to take an image, the camera beeps… it takes an image… but I still get the error screen posted earlier.

This is so frustrating… you feel like you’re one inch away from completing a marathon but can’t cross the finish line because your foot got stuck on a huge amount of chewing gum :cry:

PS: specially since the native YI360 app stopped working on my iPhone 13

Ok, might I suggest a simple and straightforward approach?

Could you add this option in the settings:

Ignore errors and continue: yes/no

Set default to no (as it is now) and when I could set it to YES, I would be able to use the camera again AND use it with the Mapillary app!

Could you add this option?

I have time to look into it this quarter. If you (or someone else) sends the camera to Mapillary I will try to make it work. No promises that I can make it work though, but I’ll do my best.

1 Like

Could you make an appointment with @mickewall ?

On the other hand, a more generic solution for those strange people with their strange camera’s, would my “ignore error and just continue” be a good idea (no camera needed then)?

Otherwise, I’ll send you mine.

Sure, any way to get it in my hands is ok. We won’t purchase it though, it’s too uncommon plus it doesn’t do onboard stitching and we don’t want unstitched images on the platform.

It’s possible, but I have to see where the error is and if I can ignore it. It could be that the camera simply stops accepting the capture command for instance, then I can’t do anything. But let’s see.

And I don’t recommend the camera anymore. I still have the opinion the hardware is great for the price (5.7k image for less then $ 200) but the software support of the camera by YI is horrible… But I can’t sell it to my self just yet to buy the QooCam 8k (my new love :wink: ) I have barely used the YI…

The error occurs immediately after the “take an image command” has been sent from the Mapillary app to the camera. The response (if any) must be not what’s expected, so the error comes on the screen. When I click the error away I can immediately take an other picture (etc).

I expect the “error screen” to be a function, so I thought that before you show the error, check if the setting “ignore_and_continue” is set to “true” and then just return without showing the error?
(I’m not an app builder, so forgive me if I’m assuming something as a PHP/Perl/bash/JS/HTML developer that is not the case here…).

If you could add that option, I think it would fix my problem. And also maybe an option to use for other (future) “exotic camera’s”!