403 UPLOAD Error

but I personally decided to also completely delete the .mapillary/logs/ subfolders in case they influenced things.

I did just that, delete my local login/config and also deleted the .mapillary folder in my images folder. Then I ran the same 2 commands I always do (first process with interpolate, asks to login (works), then upload).
I get the same 403 error sadly.

To possibly help debug the problem I have just started a small pending upload (that I processed some months ago) and it is working fine. (no 403’s) I haven’t however kept mapillary_tools up to date (7mo old) as I have my own “higher” quality ffmpeg code in there. I also run it in a env box.

I haven’t been following the code updates either. Last commit seemed around September though https://github.com/mapillary/mapillary_tools Last change to authenticate.py was also around 7 mo ago.

Might be good to take it up with support@mapillary.com direct. I have obtained help that way in the past.

I’m running this problem too in a linux box using the last version of mapillary_tools

Tried to delete ~/.config/mapillary/config, .mapillary/* in the images folder, re-authenticate, the --rerun option… no fix.

I just send a mail to support@mapillary.com

@javiersanp Any luck so far? I’m experiencing the same problem.

No. Still can’t upload and no answer for now from support.


Looks like the web upload is working again (see New Desktop Uploader). However the scripts mapillary_tools are still failing (see https://github.com/mapillary/mapillary_tools/issues/358). Not sure if this is related, though.

Got hit with this, many images pending.
Emailed Mapillary support, asking to respond in this thread - otherwise it seems pretty abandoned from their side :slight_smile:

Updated mapillary_tools from 0.4.2 to 0.5.0. This version just sits there without error messages.
Running out of diskspace, will have to stop capturing images soon :confused:

I’ve created a new thread specifically for mapillary_tools: Mapillary_tools: HTTP Error 403: Forbidden

Update from my end after 3 weeks: switched from running the python script to the pre-compiled mapillary_tools.exe, re-authenticated and tried again with the untouched files straight from the SD card. A small sample of 30 files finally worked, yay. Will retry the remaining later today.

Mine is now broken. (command line uploader linux)

Deleting config and “authenticate” no joy. I note that user_permission_hash and user_signature_hash only have changed

Laterish 050 with existing images (c/- Mapillary tags) no joy. This version also seems to hang after extracting images from the mp4’s, but I haven’t run this problem down yet. (I have an altered ffmpeg command)

I have messaged support.

Hi Everyone, I apologize for the delay on this issue. We’ve released a new version Desktop Uploader v1.2.2 and tools to fix the issues we were experiencing with this.

Users having issues with the uploader will need to:

  • wait for the uploader to auto-update to v1.2.2
  • reprocess imagery by manually deleting the .mapillary folder created in the import path

Users having issues with _tools will need to:

  • get the latest tools binary (or update to the latest master)
  • mapillary_tools authenticate --advanced (reauthorize)
  • re-process imagery by manually deleting the .mapillary folder created in the import path or using --rerun

Let us know if you run into any issues with this. Thanks!


Nice to hear, thank you! I will check as soon as time permits.

Apart from that, can you explain why Mapillary’s communication with the community is so catastrophic? Mails to support@mapillary.com are not answered at all, there is no reaction at https://forum.mapillary.com/t/mapillary-tools-http-error-403-forbidden and there is no reaction at https://github.com/mapillary/mapillary_tools/issues/358. There are no problems reported at https://status.mapillary.com/ despite significant problems existing for over a week now.

Don’t take this personally. It is totally acceptable to wait for a fix. However giving your community, existing of volunteers, the constant feeling of being ignored is not acceptable at all.


@scai Thanks, let me know when you have the time to test it out.

I will actually apologize personally for this. I’m the sole person handling our entire support@mapillary.com channel, and with the holidays as well as a massive surge of emails from people and users contacting us regarding recent large-scale projects we’ve had with mapillary.com/drive, my queue has gone from a dozen or so new issues per day to several hundred. It’s been a mix of growing pains and learning experiences with how we need to restructure support as we enter 2020. Now that the holidays are over I have the chance to catch up and get back to a speedier response-time for issues like this.

I’m also completely on board with having more information added to the status.mapillary.com page - I’ve been an advocate for this and want to make it a goal to have the status page alert for user-facing issues and not just database issues. There will only be winners if we can get that running, even if it means I need to manually update known issues I see as they come in :slight_smile:

I’ll keep the forum open to monitor this better while I handle these other requests/issues, and again, I apologize that there has been a bad case of radio silence recently and will do what I can to help.



Followed the steps for mapillary_tools and it seems to work. Upload started and no more 403 errors so far. Hope it stays this way!


Thanks for your insight! Under these circumstances the lack of response is completely understandable. Hopefully Mapillary will increase support resources soon to reduce your work load and to provide better feedback towards their community.


Hi Brenna @Brenna

You may wish to take this to a PM.

Is there any viable way to avoid the --rerun step? (mapillary_tools Linux) I have about 500,000 images on a remote upload PC and perhaps 300,000 on a local hard drive that have already been through the process step and a --rerun is going to be near impossible. Can auth for a specific user be temporarily disabled? Perhaps rsync the structure to the Mapillary server and copy from there?


I’m using a really old custom version of the tools, and it uses the MAPILLARY_SIGNATURE_HASH and MAPILLARY_PERMISSION_HASH. Is it possible to still use these tools, and if so, did the hashes change? Where would I find those?

EDIT: Never mind, I figured out that the new tools are compatible with most of my old process. Hopefully I can integrate them into my fun bash script.


We’ve just released a new version Desktop Uploader v1.2.3 and tools adding a more permanent fix , so the above steps are not necessary for the desktop uploader uploader. Upload 1.2.3 and report back if there are any issues.

@bob3bob3 - send me an email support@mapillary.com and I’ll try to find out what options we have with the dev team. Thanks!

Yes it works.